Keyboard issues with GNOME on a PowerBook G4 running OpenBSD

While setting up OpenBSD on my PowerBook, I ran across a problem with GNOME. My mouse would work fine but the moment I tried to type something, key presses would not register and mouse clicks would no longer work. The caps lock lights still worked and I could ssh to the machine so it was not locked up. Restarting X with Ctrl-Alt-Backspace seemed to be the only way out. The problem was the same if GNOME was started from GDM or from startx. FVWM from startx worked fine, so it wasn't a hardware issue.

After much searching I finally stumbled upon a thread from OpenBSD's misc@ email list that matched my problem:


The next email in the thread mentioned problems with XDM, and I too was also experiencing problems with GDM.

The third email pointed me to the right location for the solution, "the second parapgraph of /usr/X11R6/README" which states:
To use xdm from rc.conf, it is necessary to disable /dev/ttyC0 in
/etc/ttys, change the 'status' of /dev/ttyC0 to 'off'.
I remember seeing this when I initially set up X but unfortunately I didn't follow the directions (maybe because I was having the problem from startx as well as GDM). Disabling /dev/ttyC0 and rebooting solved the issue.

Comments

Don Robertson said…
Some else mad enough to put *nix onto a PPC Mac? I thought it was just me :-).

I finally got Linux going on my machine - but then lost the boot records and the DVD/CD drive. I am told I can install Grub 2 but if I screw it up I cannot reinstall - so have to live with OS X 10.4.

Pity - had KDE running and it looked great when I finally got it running.
Juliano Borges said…
This comment has been removed by the author.
Ashutosh Tiwari said…
It is really nice info. visit... us..Bookmarking site list

Popular posts from this blog

Update to Label Sphere

Label Sphere v2

Run-time and design-time selection of a ViewModel using XAML